-
Notifications
You must be signed in to change notification settings - Fork 4
/
Copy pathLinear-Search-Summation.cpp
82 lines (72 loc) · 1.51 KB
/
Linear-Search-Summation.cpp
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
Square Inc. processes thousands of transactions daily amounting to millions of dollars. They also have a daily target that they must achieve. Given a list of transactions done by Square Inc. and a daily target your task is to determine at which transaction does Square achieves the same.
Input:
First line contains T, number of transactions done by Square in a day.
The following line contains T integers, the worth of each transactions.
Next line contains Q, the no of queries.
Next Q lines contain an integer each representing the daily target.
Output:
For each query, print the transaction number where the daily limit is achieved or -1 if the target can't be achieved.
Constraints:
1<= T <=100000
1<= Ai <=1000
1<= Target <= 109
1<=Q<=1000000
Problem statement in native language : http://hck.re/7Hb1a3
SAMPLE INPUT
5
1 2 1 3 4
3
4
2
10
SAMPLE OUTPUT
3
2
5
#include<iostream>
using namespace std;
int main()
{
long long int t,i,q,j;
long long int sum=0;
long long int count=0;
cin>>t;
int k[t+1];
for(i=0; i<t;i++)
{
cin>>k[i];
}
cin>>q;
long int l[q+1];
for(j=0; j<q; j++)
{
cin>>l[j];
}
for(j=0; j<q; j++)
{
for(i=0; i<t;i++)
{
sum= sum+k[i];
if(sum>=l[j])
{
count=i;
break;
}
else if(sum<l[j])
{
count=-1;
}
}
if(count>=0)
{
cout<<count+1<<endl;
}
else
{
cout<<"-1"<<endl;
}
count=0;
sum=0;
}
return 0;
}