-
Notifications
You must be signed in to change notification settings - Fork 4
/
Copy pathMaximun-K-size-Subarray.cpp
65 lines (44 loc) · 1.33 KB
/
Maximun-K-size-Subarray.cpp
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
// Given an array A of size 'N' and an integer k, find the maximum for each and every contiguous subarray of size k.
// Input :
// First line contains 2 space separated integers 'N' and 'k' .
// Second line contains 'N' space separated integers denoting array elements.
// Output:
// Space separated Maximum of all contiguous sub arrays of size k.
// Constraints :
// 1<= N <=10^5
// 1<= Ai <=10^9
// 1<= k <=N
// SAMPLE INPUT
// 9 3
// 1 2 3 1 4 5 2 3 6
// SAMPLE OUTPUT
// 3 3 4 5 5 5 6
// Explanation
// First Sub array of size 3 : 1 2 3, here maximum element is 3
// second Sub array of size 3 : 2 3 1, here maximum element is 3
// third Sub array of size 3 : 3 1 4, here maximum element is 4
// fourth Sub array of size 3 : 1 4 5, here maximum element is 5
// Fifth Sub array of size 3 : 4 5 2, here maximum element is 5
// Sixth Sub array of size 3 : 5 2 3, here maximum element is 5
// Seventh Sub array of size 3 : 2 3 6, here maximum element is 6
#include<bits/stdc++.h>
using namespace std;
int main()
{
long long int n,m,i,j,maxi=0;
cin>>n>>m;
long long int a[n+1];
for(i=0; i<n; i++)
{
cin>>a[i];
}
for(i=0; i<=n-m; i++)
{
for(j=i; j<i+m; j++)
{
maxi = max(maxi , a[j]);
}
cout<<maxi<<" ";
maxi=0;
}
}