-
Notifications
You must be signed in to change notification settings - Fork 4
/
Copy pathQuick-Sort3.cpp
74 lines (65 loc) · 1.86 KB
/
Quick-Sort3.cpp
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
Chandu's girlfriend loves arrays that are sorted in non-increasing order. Today is her birthday. Chandu wants to give her some sorted arrays on her birthday. But the shop has only unsorted arrays. So, Chandu bought T unsorted arrays and is trying to sort them. But, he doesn't have much time to sort the arrays manually as he is getting late for the birthday party. So, he asked you to write a program to sort the T arrays in non-increasing order. Help him, or his girlfriend will kill him.
Input:
First line contains an integer T, denoting the number of test cases.
First line of each test case contains an integer N, denoting the size of the array.
Second line contains N space separated integers, denoting the array elements Ai.
Output:
For each test case, print the sorted array in non-increasing order.
Constraints:
1 <= T <= 100
1 <= N <= 105
0 <= Ai <= 109
SAMPLE INPUT
2
5
2 5 2 4 3
5
5 4 2 3 1
SAMPLE OUTPUT
5 4 3 2 2
5 4 3 2 1
#include<bits/stdc++.h>
using namespace std;
int partition(int *a , int start , int end)
{
int pivot = a[end];
int pindex = start;
for(int i= start ; i<end; i++)
{
if(a[i]<=pivot)
{
swap(a[i] , a[pindex]);
pindex++;
}
}
swap(a[pindex] ,a[end]);
return pindex;
}
int quicksort(int *a , int start , int end)
{
if(start < end)
{
int pindex = partition(a,start , end);
quicksort(a,start ,pindex-1);
quicksort(a,pindex+1 , end);
}
}
int main()
{ int t,i,j,m;
cin>>t;
for(i=0; i<t; i++)
{
cin>>m;
int a[m+1];
for(j=0; j<m; j++)
{
cin>>a[j];
}
quicksort(a,0,m-1);
for(j=m-1; j>=0; j--)
{
cout<<a[j]<<" ";
}
cout<<"\n";
}
}