-
Notifications
You must be signed in to change notification settings - Fork 4
/
Copy pathSearching-in-Binary-Search-Tree.cpp
118 lines (109 loc) · 2.52 KB
/
Searching-in-Binary-Search-Tree.cpp
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
// Monk is standing at the door of his classroom. There are currently N students in the class, i'th student got Ai candies.
// There are still M more students to come. At every instant, a student enters the class and wishes to be seated with a student who has exactly the same number of candies. For each student, Monk shouts YES if such a student is found, NO otherwise.
// Input:
// First line contains an integer T. T test cases follow.
// First line of each case contains two space-separated integers N and M.
// Second line contains N + M space-separated integers, the candies of the students.
// Output:
// For each test case, output M new line, Monk's answer to the M students.
// Print "YES" (without the quotes) or "NO" (without the quotes) pertaining to the Monk's answer.
// Constraints:
// 1 ≤ T ≤ 10
// 1 ≤ N, M ≤ 105
// 0 ≤ Ai ≤ 1012
// SAMPLE INPUT
// 1
// 2 3
// 3 2 9 11 2
// SAMPLE OUTPUT
// NO
// NO
// YES
// Explanation
// Initially students with 3 and 2 candies are in the class.
// A student with 9 candies enters, No student with 9 candies in class. Hence, "NO"
// A student with 11 candies enters, No student with 11 candies in class. Hence, "NO"
// A student with 2 candies enters, Student with 2 candies found in class. Hence, "YES"
#include<bits/stdc++.h>
using namespace std;
struct Binary
{
int data;
Binary *left;
Binary *right;
};
Binary *newNode (int data)
{
Binary *node = new Binary ();
node->data = data;
node->left = node->right = NULL;
return node;
}
Binary *insert (Binary * root, int data)
{
if (root == NULL)
{
root = newNode (data);
}
else if (data <= root->data)
{
root->left = insert (root->left, data);
}
else
{
root->right = insert (root->right, data);
}
return root;
}
bool Search (Binary * root, int data)
{
if (root == NULL)
{
return false;
}
else if (root->data == data)
{
return true;
}
else if (data <= root->data)
{
return Search (root->left, data);
}
else
{
return Search (root->right, data);
}
}
int main ()
{
long long int i,n,t,j,k,m;
cin>>t;
for(j=0; j<t; j++)
{
cin>>n>>m;
long long int a[n+m+1],b[n+m+1];
for (i = 0; i < n; i++)
{
cin >> a[i];
}
Binary *root;
root = NULL;
for (i = 0; i < n; i++)
{
root = insert (root, a[i]);
}
for(k=n; k<n+m; k++)
{
cin>>b[k];
if (Search (root, b[k]) == true)
{
cout << "YES\n";
}
else
{
cout << "NO\n";
}
root = insert (root, b[k]);
}
}
}