-
Notifications
You must be signed in to change notification settings - Fork 4
/
Copy pathSub-Array-Division.cpp
57 lines (47 loc) · 1.25 KB
/
Sub-Array-Division.cpp
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
Here is your task. You are given an array and you have to find the maximum possible length of subarray In that subarray a[i+1]%a[i]==0 Every element in subarray is divisible by its previous element Your task is to find maximum length of subarray.
INPUT
first line conatin number of test cases T. Each test case contain number of element in array N.Next line contain elements of array.
OUTPUT
print maximum length of subarray
Constraints
1<=T<=100 1<=N<=1000000 1<=a[i]<=1000000
SAMPLE INPUT
1
6
5 3 10 12 25 20
SAMPLE OUTPUT
3
Explanation
Subarray of maximum length conatins 5 10 20
#include <iostream>
#include<algorithm>
using namespace std;
int main()
{
long long int n,t,i,j,ans;
cin>>t;
while(t--)
{
cin>>n;
long long int a[n],l[n];
for(i=0;i<n;i++)
{
cin>>a[i];
}
sort(a,a+n);
for(i=0;i<n;i++)
l[i]=1;
ans=0;
for(i=0;i<n;i++)
{
for(j=0;j<i;j++)
{
if(a[i]%a[j]==0)
l[i] = l[i]>l[j]+1 ? l[i]:l[j]+1 ;
}
ans = ans>l[i] ? ans : l[i];
}
cout<<ans<<endl;
}
return 0;
}