-
Notifications
You must be signed in to change notification settings - Fork 0
/
Copy pathCurrency_Formatter.java
176 lines (152 loc) · 4.97 KB
/
Currency_Formatter.java
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
package technicals;
/*Given a double-precision number, , denoting an amount of money, use the NumberFormat class' getCurrencyInstance method to convert into the US, Indian, Chinese, and French currency formats. Then print the formatted values as follows:
US: formattedPayment
India: formattedPayment
China: formattedPayment
France: formattedPayment
where is formatted according to the appropriate Locale's currency.
Note: India does not have a built-in Locale, so you must construct one where the language is en (i.e., English).
Input Format
A single double-precision number denoting .
Constraints
Output Format
On the first line, print US: u where is formatted for US currency.
On the second line, print India: i where is formatted for Indian currency.
On the third line, print China: c where is formatted for Chinese currency.
On the fourth line, print France: f, where is formatted for French currency.
Sample Input
12324.134
Sample Output
US: $12,324.13
India: Rs.12,324.13
China: ¥12,324.13
France: 12 324,13 €*/
import java.util.*;
import java.text.*;
public class Currency
{
//method 1
//For USA format
static String USA( double payment)
{
String usa="$";
int c =(int)Math.log10(payment)+1; //counting number of digits
int count =0;
String res="";
String st = Double.toString(payment);
for(int i =0;i<st.length()-1;i++)
{
if((c-count)%3==0 && (c-count)>0 && i!=0)
{
res=res+","+st.charAt(i);
}
else
{
res=res+st.charAt(i);
}
count++;
}
return usa+ res;
}
//For Indian Format
static String India( double payment)
{
String usa="Rs.";
int c =(int)Math.log10(payment)+1;
int count =0;
String res="";
String st = Double.toString(payment);
for(int i =0;i<st.length()-1;i++)
{
if((c-count)%3==0 && (c-count)>0 && i!=0)
{
res=res+","+st.charAt(i);
}
else
{
res=res+st.charAt(i);
}
count++;
}
return usa+ res;
}
//For Chinese Format
static String China( double payment)
{
String usa="\u00A5"; //unicode for using ¥
int c =(int)Math.log10(payment)+1;
int count =0;
String res="";
String st = Double.toString(payment);
for(int i =0;i<st.length()-1;i++)
{
if((c-count)%3==0 && (c-count)>0 && i!=0)
{
res=res+","+st.charAt(i);
}
else
{
res=res+st.charAt(i);
}
count++;
}
return usa+ res;
}
//For Indian Format
static String France( double payment)
{
String usa="\u20AC"; //unicode for using €
int c =(int)Math.log10(payment)+1;
int count =0;
String res="";
String st = Double.toString(payment);
for(int i =0;i<st.length()-1;i++)
{
if((c-count)%3==0 && (c-count)>0 && i!=0)
{
res=res+" "+st.charAt(i);
}
else if(st.charAt(i)=='.')
{
res=res+",";
}
else
{
res=res+st.charAt(i);
}
count++;
}
return res+" "+usa;
}
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
double payment = scanner.nextDouble();
System.out.println("US: " + USA(payment));
System.out.println("India: " + India(payment));
System.out.println("China: " + China(payment));
System.out.println("France: " + France(payment));
}
}
//method 2 -- By using NumberFormat Class from java.text package
/*
* public class Solution {
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
double payment = scanner.nextDouble();
scanner.close();
NumberFormat n = NumberFormat.getCurrencyInstance(Locale.US);
String us = n.format(payment);
NumberFormat n1 = NumberFormat.getCurrencyInstance(new Locale("en", "IN")); //Creates a new Locale with English as the language and India as country
String india = n1.format(payment);
NumberFormat n2 = NumberFormat.getCurrencyInstance(Locale.CHINA);
String china = n2.format(payment);
NumberFormat n3 = NumberFormat.getCurrencyInstance(Locale.FRANCE);
String france = n3.format(payment);
// Write your code here.
System.out.println("US: " + us);
System.out.println("India: " + india);
System.out.println("China: " + china);
System.out.println("France: " + france);
}
}
*/