-
Notifications
You must be signed in to change notification settings - Fork 10
/
Copy path09_lower_upper.cpp
57 lines (44 loc) · 1.12 KB
/
09_lower_upper.cpp
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
/*
Problem Name: Lower Upper
Print "lowercase" if user enters a character between 'a-z' ,
Print "UPPERCASE" is character lies between 'A-Z' and
print "Invalid" for all other characters like $,.^# etc.
Input Format: Single Character
Constraints: No constraints
Output Format: lowercase UPPERCASE Invalid
Sample Input: $
Sample Output: Invalid
Explanation: NA
*/
#include <iostream>
#include <string>
using namespace std;
// function to print character type
void getCharacterType(char ch)
{
if(ch >= 'A' && ch <= 'Z'){
cout << "UPPERCASE";
}else if(ch >= 'a' && ch <= 'z'){
cout << "lowercase";
}else{
cout << "Invalid";
}
}
int main()
{
char ch;
cout << "Enter you character: ";
cin >> ch;
getCharacterType(ch);
cout << endl;
return 0;
}
/*
Algo
1.Take Input of the character from the User.
2.Chech if the character is in UpperCase ( if is between A - Z).
Then, print UPPERCASE
3.If the character is in LowerCase ( If character is in between a - z) .
Print lowercase
4.Otherwise, Print Invalid.
*/